errors restoring jetbackup 5

cPanel, Industry leading hosting platform with world-class support.
Post Reply
ludolugo
Posts: 23
Joined: April 17th, 2020, 10:40 am

errors restoring jetbackup 5

Post by ludolugo »

Hi,
When restoring a full backup i see the following errors:

Code: Select all

12/Nov/2021 10:23:49 +0000] [PID 51195] [ERROR] Failed making API Call to cPanel/WHM (uapi). Error: Failed to parse adminbin request: Account is suspended at /usr/local/cpanel/Cpanel/AdminBin/Server.pm line 101.


[12/Nov/2021 10:23:49 +0000] [PID 51195] Restoring database user "[email protected]"

[12/Nov/2021 10:23:49 +0000] [PID 51195] [ERROR] Failed making API Call to cPanel/WHM (uapi). Error: Failed to parse adminbin request: Account is suspended at /usr/local/cpanel/Cpanel/AdminBin/Server.pm line 101.


[12/Nov/2021 10:23:49 +0000] [PID 51195] Restoring database user "[email protected]"

[12/Nov/2021 10:23:50 +0000] [PID 51195] [ERROR] Failed making API Call to cPanel/WHM (uapi). Error: Failed to parse adminbin request: Account is suspended at /usr/local/cpanel/Cpanel/AdminBin/Server.pm line 101.


[12/Nov/2021 10:23:50 +0000] [PID 51195] Restoring database user "[email protected]"

[12/Nov/2021 10:23:50 +0000] [PID 51195] [ERROR] Failed making API Call to cPanel/WHM (uapi). Error: Failed to parse adminbin request: Account is suspended at /usr/local/cpanel/Cpanel/AdminBin/Server.pm line 101.


[12/Nov/2021 10:23:50 +0000] [PID 51195] Restoring homedir

[12/Nov/2021 10:50:34 +0000] [PID 51195] Restoring email account "[email protected]"

[12/Nov/2021 10:50:35 +0000] [PID 51195] [ERROR] Failed making API Call to cPanel/WHM (uapi). Error: Failed to parse adminbin request: Account is suspended at /usr/local/cpanel/Cpanel/AdminBin/Server.pm line 101.
 


[12/Nov/2021 10:50:35 +0000] [PID 51195] Restoring email account "[email protected]"

[12/Nov/2021 10:50:35 +0000] [PID 51195] [ERROR] Failed making API Call to cPanel/WHM (uapi). Error: Failed to parse adminbin request: Account is suspended at /usr/local/cpanel/Cpanel/AdminBin/Server.pm line 101.
 


[12/Nov/2021 10:50:35 +0000] [PID 51195] Restoring email account "[email protected]"

[12/Nov/2021 10:50:36 +0000] [PID 51195] [ERROR] Failed making API Call to cPanel/WHM (uapi). Error: Failed to parse adminbin request: Account is suspended at /usr/local/cpanel/Cpanel/AdminBin/Server.pm line 101
Also when restoring a DB with different prefix tan the username it sais that it can not restore it because the prefix is different, this happens with several accounts that has been migrated from cpanel with mariadb to cpanel with mysql8 , and cpanel changes the username to 8 characters
This is the error [
ERROR] Failed making API Call to cPanel/WHM (uapi). Error: The name “protrasplantep_wp” does not begin with the required prefix “protrasp_”
JetAppsRichard
Staff Member
Staff Member
Posts: 96
Joined: January 1st, 2021, 12:51 am

Re: errors restoring jetbackup 5

Post by JetAppsRichard »

Hello ludolugo,

Thank you for reaching out through our forums. The first error from the snippet you provided is the following:

Code: Select all

[ERROR] Failed making API Call to cPanel/WHM (uapi). Error: Failed to parse adminbin request: Account is suspended at /usr/local/cpanel/Cpanel/AdminBin/Server.pm line 101.
This error occurs when the account was suspended when backed up so JetBackup is suspending the account upon restore. As you may know, JetBackup utilizes the Panel API in order to perform Backups/Restores, and in this case, cPanel does not allow suspended accounts to utilize their API resulting in this error. In order to work around this issue, when on the confirmation page to "Restore Filtered Accounts" ensure that the option "Suspend account after restore" is NOT selected and the account will be unsuspended during restore allowing other items to complete.

For the second issue regarding the Database prefix, this is a known issue with the cPanel Tweak Setting Require a username prefix on names of new databases and database users. In order to allow a restore of Databases without the proper prefix you would need to disable this Tweak Setting from WHM Home > Tweak Settings > “Require a username prefix on names of new databases and database users” then perform the restore again. You can find more information on this in our Knowledgebase here: Restore Failed: Error while trying to get data from uapi/whmapi

Please let us know if the issue persists or you have any other questions.
Best Regards,
Richard, JetApps Team
Post Reply